MagicEngine
Forums
 
 よくある質問よくある質問   検索検索   メンバーリストメンバーリスト   グループグループ   登録登録 
 ユーザー設定ユーザー設定   PM確認のためにログインPM確認のためにログイン   ログインログイン 
 Japanese English 

DirectX9で動かない?

 
トピックの新規投稿   返信    MagicEngine フォーラム一覧 -> サポート
前のトピックを表示 :: 次のトピックを表示  
投稿者 メッセージ
takacha
ゲスト
ゲスト


登録日: 200971月 11日
投稿記事: 4

投稿1時間: 日 1月 11, 2009 10:37 am    題名: DirectX9で動かない? 引用

MagicEngine Ver1.13を Thinkpad X21で利用しています。
今までは問題なく動いていたのですが、
DirectX9をインストールした後、起動できなくなってしまいました。

エラーはwindowsからのメッセージで、「問題が発生したため、pce.exeを終了します」と出ます。

DirectX8に戻せば動くと思いますが、それも大変ですし。。。。。

DirectX9には対応していないのでしょうか??
トップに移動
ユーザー情報を表示 メッセージを送信
dmichel
管理人
管理人


登録日: 200363月 15日
投稿記事: 227
所在地: France

投稿1時間: 水 1月 14, 2009 12:03 am    題名: 引用

MagicEngineはDirectX8を使用する。
しかしそれはDirectX9が取付けられていればも動く。

マイ・コンピュータで私はDirectX9.0cを使用し、MagicEngineはよく動いている。

どのようなエラーメッセージに得るか?何であるか?
_________________
David Michel
トップに移動
ユーザー情報を表示 メッセージを送信
takacha
ゲスト
ゲスト


登録日: 200971月 11日
投稿記事: 4

投稿1時間: 水 1月 14, 2009 2:48 pm    題名: 引用

magicengineを起動すると、下記のエラーが起こります。

---------------------------------------------------------------------
問題が発生したため、pce.exeを終了します。ご不便をおかけして申し訳ありません。

エラー報告に含まれるデータの参照
Appname: pce.exe AppVer:0.0.0.0 ModName: pce.exe
ModVer: 0.0.0.0 Offset: 00016a96

---------------------------------------------------------------------

その他の情報

・video driverがOpenGLの場合は、magicengineは正常に起動しますが、非常に遅いです。
・Direct3Dを無効にすると、エラーは起こりませんが、magicengineのメニュー画面が表示されません。
・Dxdiagの結果はこちらです
 http://takacha-spl.cocolog-nifty.com/DxDiag.txt

以上、ご確認よろしくお願いします。
トップに移動
ユーザー情報を表示 メッセージを送信
dmichel
管理人
管理人


登録日: 200363月 15日
投稿記事: 227
所在地: France

投稿1時間: 土 1月 17, 2009 2:04 am    題名: 引用

DirectX9取付けは良いようである。
私はそれがなぜ働いていないか知らない。 Embarassed
問題はMagicEngineのより古い版と起こるもか?
_________________
David Michel
トップに移動
ユーザー情報を表示 メッセージを送信
takacha
ゲスト
ゲスト


登録日: 200971月 11日
投稿記事: 4

投稿1時間: 土 1月 17, 2009 3:23 pm    題名: 引用

こんばんは。

古いversionのmagicengineで試してみました。

v0.9.9 beta5 は問題なく動作します。

Ver1.0.0 はエラーが起こります。 initialization error : -3
(openGLでは問題なく動作しますが、非常に遅いです。)

よろしくお願いします。
トップに移動
ユーザー情報を表示 メッセージを送信
takacha
ゲスト
ゲスト


登録日: 200971月 11日
投稿記事: 4

投稿1時間: 木 2月 19, 2009 1:55 pm    題名: 直りました 引用

その後色々と試した結果、無事動作するようになりました。 Very Happy

下記のソフトをアンインストールしたところ動くようになったのですが、
どれが悪かったのかははっきりしていません。

1. .NET framework 3.5
2. Visual C# 2008 express
3. 上記に関連するアップデート

あまり参考にならないかと思いますが、ご報告します。
トップに移動
ユーザー情報を表示 メッセージを送信
特定期間内の記事を表示:   
トピックの新規投稿   返信    MagicEngine フォーラム一覧 -> サポート All times are 中央ヨーロッパ標準時 (欧州)
Page 1 of 1

 
移動先:  
新規投稿: 不可
返信: 不可t
自分の記事の編集: 不可
自分の記事の削除: 不可
投票への参加: 不可


Powered by phpBB © 2001, 2005 phpBB Group